21.10 Desktop double crash, kwin_x11 100%

Thank you for your efforts. Decided to try it out but after install on a Lenovo V340-17IWL the desktop crashes after about 1-2 sec. and reloads a black (empty?) wallpaper with a grey non-transparent activity toolbar, and after a little while that crashes out too, but wallpaper returns. Sometimes I can trigger the menu with the super key and start some of the listed apps, like terminal. Control center starts but hangs after one click and (I suppose) leaves a non-reactive ghost image of it on screen. When doing top kwin_x11 shows 100% cpu for hours on end with nothing more happening. apt update with new kernel as of today (2021-01-05) but no difference. Tips to trace?

Follow up:
In the first post I had autologin enabled after I hardly had time to enter password before gui crash. Did a reinstall today and did not enable autologin, and when I hurried to enter the password I misspelled and pressed enter whereafter it crashed as usual but to a login shell prompt and then reloaded lightdm for gui login. After that the desktop appears as it should, with no consecutive crash.
So, today’s workaround seems to be:

  1. don’t set autologin
  2. type wrong password and press enter before the gui crash (about 2 sec)
  3. wait for gui reload and login as usual

In the logs these lines appear:

2022-01-10 17:35	v340	lightdm	PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
2022-01-10 17:35	v340	lightdm	PAM adding faulty module: pam_kwallet.so
2022-01-10 17:35	v340	lightdm	PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
2022-01-10 17:35	v340	lightdm	PAM adding faulty module: pam_kwallet5.so

I had login issues similar to yours. I have tried 4 lenovo laptops, all different models, all exhibit the same issues –

  1. autologin ON seems to hang the system upon booting into desktop. Related to point 2.
  2. autologin OFF, at boot into desktop, most of the time it shows your login prompt, but then fades to black and never comes back. Requires reboot. In order to get the prompt back and actually login you need to press ESC as soon as you see the first flash of your login prompt. I found the solution here (this reddit post was over a year ago): https://www.reddit.com/r/UbuntuDDE/comments/jldaja/blackscreen_after_showing_login_page_briefly/
    The changelog for this version of ubuntu dde specifically states the fix for this issue, but it seems it’s still with us.
    Good luck guys. This distro looks and behaves awesome but unstable for me.
1 Like